您的位置:首页 > 教程 > JAVA/JAVA编程 > 快速解决VS Code报错:Java 11 or more recent is required to run. Please download and install a recent JDK

快速解决VS Code报错:Java 11 or more recent is required to run. Please download and install a recent JDK

2020-09-05 07:02:41 来源:易采站长站 作者:

快速解决VS Code报错:Java 11 or more recent is required to run. Please download and install a recent JDK,版本,插件,编译器,不太,这个问题

快速解决VS Code报错:Java 11 or more recent is required to run. Please download and install a recent JDK

易采站长站,站长之家为您整理了快速解决VS Code报错:Java 11 or more recent is required to run. Please download and install a recent JDK的相关内容。

VS Code确实不是最好的Java编译器(好吧,它或许都不该算是个编译器),在使用的过程完全依赖咱们自己写一些配置或者使用一些插件,但是因为它外观好看,我还是比较喜欢用这个。哪怕遇到的问题比别的编译器多得多。排查错误原因的过程中也能学到不少东西。
近期遇到这个问题,每次打开VS Code的时候,右下角会弹出一个弹框,上面写着:
Java 11 or more recent is required to run. Please download and install a recent JDK.
Source: Language Support for Java™ by Red Hat

这是当时发生错误时的截图

目前来看,这个错误并不严重,关掉弹框还是可以正常写代码、启动项目的。但是每次启动的时候都有这么个弹框让人不太舒服。
这个错误是Language Support for Java™ by Red Hat这个插件报出来的,其原因是这个插件鼓励开发者们使用Java 11或者更新的版本。在v0.64.1这个版本更新中,这个插件将Java 11作为运行版本。

解决方案

对于这个问题的解决方案有两个:

方案一:

既然v0.64.1版本往后支持的最低版本为Java 11,那么可以在自己的电脑上安装Java 11,并将环境变量指向Java 11的home,这样就可以正常使用了。这么处理之后,工程的编译等操作还是可以使用Java 8或者其他版本的,但是这得在工程的配置文件里做一些配置。

方案二:

升级Java 11并不是唯一的方案,很多情况下我们不太方便升级Java的版本。对此还有一个办法就是将这个插件回退到更低的版本。只要是v0.64.1版本之前的都可以。然后记得关掉VS Code的自动更新,不然这货分分钟把这个插件升级回来(网络状况好的话)。回退的方法见下图:

Language Support for Java(TM) by Red Hat插件回退方法

点击插件右下角的设置按钮,选择“Install Another Version”,然后选择v0.64.1版本之前的即可。

总结

到此这篇关于快速解决VS Code报错:Java 11 or more recent is required to run. Please download and install a recent JDK的文章就介绍到这了,更多相关VS Code报错内容请搜索易采站长站以前的文章或继续浏览下面的相关文章希望大家以后多多支持易采站长站!

以上就是关于对快速解决VS Code报错:Java 11 or more recent is required to run. Please download and install a recent JDK的详细介绍。欢迎大家对快速解决VS Code报错:Java 11 or more recent is required to run. Please download and install a recent JDK内容提出宝贵意见

微信扫一扫

易采站长站微信账号