win10安装python3.6的常见问题

2020-07-01 18:01 来源:易采站长站 作者:王冬梅 点击: 评论:

A-A+

原标题:win10安装python3.6的常见问题

1.python下载

https://www.python.org/downloads/

2.x和3.x版本都行吧,都可以下的。(然后安装的时候,记得勾选环境变量配置就行了,当然也可以自己配)

我下载的是python 3.6版本。

2.python如何查看安装的模块

在cmd下pip list

3.python如何安装模块

1)可以pip install ‘module模块名称'

2)也可以在https://www.lfd.uci.edu/~gohlke/pythonlibs/网站下载whl,然后用pip install xxx.whl就能安装(也是在cmd下)。(记住,从这个网站下的时候,模块的版本一定要和python版本一致,比如numpy-1.15.0rc1+mkl-cp36-cp36m-win_amd64 对应3.6版本,64位操作系统)

4.ImportError: DLL load failed: 找不到指定的模块。 发生这样的错误怎么办?

错误原因:安装包的来源问题,也可以理解为包版本兼容问题,有的包使用官方出版,有的包使用whl文件安装

解决方案:将所有包都统一来源,要么全部使用官方出版的包,要么全部使用whl里面的包,问题就解决了 [1]

python学习网,免费的python学习网站,欢迎在线学习!

我在安装numpy,scikit-learn,scipy的时候,numpy是用pip install安装的,其他是从https://www.lfd.uci.edu/~gohlke/pythonlibs/上下载的,所以可能安装包来源不一致,导致了这个问题,我用pip uninstall numpy把numpy卸载,然后从网站上下numpy,用pip install安装即可。

5.NameError: name ‘xrange' is not defined

因为我是python3.6版本,xrange函数已经被移除,不过range函数就可以实现xrange的功能。

6.想改回python 2版本怎么办,怎么自由切换?

1)下载python2.7版本(我下载的是:python-2.7.15.amd64.msi),然后安装,默认安装即可。

2)默认安装没有配置环境变量,那么在环境变量(其实系统变量和用户变量都行,在path中新建就行)中添加C:\Python27\Scripts和C:\Python27(这是python的默认安装地址)。

3)把python 3.6 根目录(我的在C:\Users\dehen\AppData\Local\Programs\Python\Python36)的python.exe改成xxx.exe(只要不是python.exe就行) [2]。

4)在cmd下python --version,就会发现版本已经变成了2.7

5)同样,把2.7根目录(我的在C:\Python27)下的python.exe名字改了,把3.6版本的exe名字改回来,即可发现版本切换到了3.6.

注意:切换到2.7版本后,原来下载的模块又要重新下载了。所以要用到pip,2.7版本下用pip2.3.6版本用pip3。

内容扩展:

WIN10安装PYTHON和一些模块的过程

其实非常简单,就是记录一下,怕以后忘了,又去百度,麻烦。

1.去官网(https://www.python.org/) 下载PYTHON,需要xindows版本的,x86 64位的安装程序

例:python-3.7.3-amd64.exe

2. 直接双击python-3.7.3-amd64 安装,注意在安装时,最好选择”加入环境变量" 。

【易采站长站编辑:秋军】