您的位置:首页 > 电商 > 支付结算 > 当启动vue项目安装依赖时报错的解决方案

当启动vue项目安装依赖时报错的解决方案

2022-04-02 11:53:53 来源:易采站长站 作者:

当启动vue项目安装依赖时报错的解决方案,报错,版本,项目,原因,都会

当启动vue项目安装依赖时报错的解决方案

易采站长站,站长之家为您整理了当启动vue项目安装依赖时报错的解决方案的相关内容。

目录
启动vue项目安装依赖报错暂时想到四个原因vue必备安装依赖1.elementUI2.安装sass3.安装axios4.安装vuex5.安装js-cookie

启动vue项目安装依赖报错

当启动vue项目安装依赖时报错

暂时想到四个原因

1.node版本低,升级到新版本

2.执行npm cache clean,再重新npm install

3.如果是下载依赖包失败的话,可以使用cnpm淘宝镜像下载,或者yarn下载安装

4.报错一般都会有错误提示,根据错误提示进行操作 

vue必备安装依赖

1.elementUI

npm i element-ui -S

main.js中引用

/*引入下面三行*/
import ElementUI from 'element-ui';
import 'element-ui/lib/theme-chalk/index.css';
Vue.use(ElementUI);

2.安装sass

npm install sass-loader node-sass --save-dev

在build文件夹下的webpack.base.conf.js的rules里面添加配置

{
    test: /.sass$/,
    loaders: ['style', 'css', 'sass']
}

如果报错:node-sass 6.0.0版本与^4.0.0不兼容(Node Sass version 6.0.0 is incompatible with^4.0.0)

先卸载之前版本的node-sass

npm uninstall node-sass
npm install -g cnpm --registry=https://registry.npm.taobao.org
npm install node-sass@4.14.1

3.安装axios

npm install axios -S

4.安装vuex

npm install vuex --save   或者  cnpm install vuex --save

5.安装js-cookie

npm install js-cookie --save

以上为个人经验,希望能给大家一个参考,也希望大家多多支持易采站长站。 

以上就是关于对当启动vue项目安装依赖时报错的解决方案的详细介绍。欢迎大家对当启动vue项目安装依赖时报错的解决方案内容提出宝贵意见

微信扫一扫

易采站长站微信账号